MikroKopter - Forum » Subversion - Projekte » MK iPhone App - iKopter

MK iPhone App - iKopter

Neues Thema Antwort

Seite: 1 2 3 4 5 ... > »

Autor Neuer Beitrag
MK-Betatester
Registriert seit: Mar 2010
Beiträge: 374
Ort: DA
Da die Informationen über die App in verschiedenen Threads verteilt sind (hier und hier) fange ich einen neuen Thread an, damit neue Informationen besser zu finden sind.

iKopter ist eine iPhone-App um Aufgaben rund um den MikroKopter zu erfüllen (ähnlich dem MikroKopter-Tool oder DUBWise).

Weitere Infos im Wiki: http://mikrokopter.de/ucwiki/iKopter

--------------------------------------------------------------------------------------------------------------------------------

Ab jetzt (0.3.0) gibt es auch noch eine Bluetooth-Unterstützung.
Mitglied
Registriert seit: Jun 2010
Beiträge: 6
Hallo Frank !

Erst einmal vielen dank für deine App!

Ich hatte bis jetzt die Version 0.2.0 problemlos auf meinem iPhone 3Gs mit iOS 4.3.3 und Wi 232 am laufen.

Vorhin habe ich versucht die App über Cydia auf dem neusten stand (Version 0.3.0) zu bringen, dies jedoch erfolglos...
Seit dem update lässt sich iKopter nicht mehr starten, die App zeigt nur noch kurz (ca. eine Sekunde lang) das Startbild an und geht dann wieder aus.

Die App löschen, iPhone neustarten, App installieren und wieder neustarten hat leider auch nichts gebracht.

Könnte es sein, dass man mit der neuen iKopter Version das BTStack paket installiert haben muss, damit die App läuft auch wenn man kein Bluetooth nutzt?

Gruß
vering
MK-Betatester
Registriert seit: Mar 2010
Beiträge: 374
Ort: DA
Autsch, das hatte ich schon befürchtet.

Ja, BTStack ist eine Voraussetzung. Ich muss das noch im Paket als Requirement eintragen, das habe ich heute Morgen vergessen.

Danke fürs testen

Frank
Mitglied
Registriert seit: Aug 2007
Beiträge: 651
Ort: Hamburg
ähm ... wo findet man denn den BTStack und kann man es manuell nachinstallieren ?

Haydar
MK-Betatester
Registriert seit: Mar 2010
Beiträge: 374
Ort: DA
In Cydia kannst du danach einfach suchen und dann installieren.
Mitglied
Registriert seit: May 2009
Beiträge: 129
welches BTstack ist gemeint?

Ich finde da einmal eins für die Tastatur und eins für eine Maus.

Muss ich dann die Verbindung über das BTstack herstellen und dann

ins Ikopter Menü gehen?
Mitglied
Registriert seit: Aug 2007
Beiträge: 651
Ort: Hamburg
ahh ... man muß die Cydia-Einstellung von "Benutzer" auf "Entwickler" stellen, sonst findet man den BTStack nicht.
Danke für die App, sie läuft schon mal.
Heute abend versuche ich die Verbindung per Bluetooth zum Mikrokopter

Haydar
Mitglied
Registriert seit: Aug 2007
Beiträge: 32
Wollte es auch antesten. Komme leider nicht weiter.

- BT Modul aus dem Shop
- BTStack installiert
- Kopter wird im iKopter gefunden

Beim Verbinden steigt die App nach einer halben Minute aus.

Ich vermute es könnte daran liegen, daß ich einen PIN zum Pairen im BT Modul drin habe.
Beim Connecten wird dieser aber an keiner Stelle abgefragt.
Mitglied
Registriert seit: Mar 2011
Beiträge: 844
Ort: Graz
Hallo !

Habe gerade ein Update gemacht.
Nun startet die applikation und es kommt sofort der iphone schirm wieder.
kein app menü !
Im Hintergrund läuft die Applikation aber.

Fritz

Edit :

Es ist definitv so, dass man den BTStack installieren muss, sonst läuft die app nicht.
Auch wenn man über WI232 verbinden möchte.

Fritz
« Bearbeitet von fritz99 am 09.05.2011 18:53. »
MK-Betatester
Registriert seit: Jan 2008
Beiträge: 2633
Ort: Schweiz
Vorab, cooles Teil! ;)

Ich habe die App installiert und dann den BTstack.
Eine Verbindung zum Kopter mit dem BTModul und v0.82er Firmware kommt zustande,
aber nach "NaviCTRL gefunden" kehrt das Programm zur Auswahl der Verbindungen zurück. Oder stürzt ab.
Habe allerdings noch 4.1 auf dem iPhone drauf.

Gruss Martin
MK-Betatester
Registriert seit: Mar 2010
Beiträge: 374
Ort: DA
Dank für die Tests,

die Abhängigkeit vom BTStack leg ich noch im Paket fest.

@mastergizmo die Pin ist momentan 0000, ich denk mir da noch was aus.

Gruß
Frank
Mitglied
Registriert seit: Aug 2007
Beiträge: 651
Ort: Hamburg
Hallo Frank,

nochmal großes Lob für die App.
Ich hab sie mit iPhone 4 und iOS 4.2.1 über Bluetooth getestet, funktioniert erstmal ganz gut.
Ich kann die Parameter sehen und ändern, Motortest funktioniert auch usw.
Aber die App stürzt gerne öfter ab und speichert eine neue Verbindung, die ich anlege, Namen und Verbindungstyp vergebe usw. , nicht ab.
Ich muß jedesmal, wenn ich mich mit dem MK verbinden will, neu konfigurieren und per Bluetooth suchen.

Falls Bedarf besteht, stelle ich mich gerne als Betatester zu Verfügung. Ich besitze ein iPhone 3GS und 4 und ein iPad 1.

Gruß
Haydar
Mitglied
Registriert seit: Aug 2007
Beiträge: 32
Habs BT jetzt zum Laufen gebracht. :P

BT PIN habe auf '0000' gesetzt.
Muss nur kurz vor dem Verbinden das BT-Modul einstecken, dann funktionierts.

Das Problem mit dem Abspeichern der Konfiguration funktioniert bei mir auch nicht.
Nach jedem App neustart muss die Verbindung neuangelegt werden.

iPhone 4 - OS 4.3.3
MK-Betatester
Registriert seit: Mar 2010
Beiträge: 374
Ort: DA
Das abspeichern kann ich nachvollziehen, hat bestimmt was mit Zugriffsrechten zu tun.

Für die PIN habe ich in der neuesten Version 0.3.1 die Möglichkeit vorgesehen, dass man die manuell am Ende der Adresse angeben kann. In der Form aa:bb:cc:dd:ee:fff#0000. Ich habe es aber noch nicht richtig getestet.

Ab der Version ist jetzt auch der BTStack als Abhängigkeit definiert und wird automatisch mit installiert.
MK-Betatester
Registriert seit: Sep 2007
Beiträge: 2741
Ort: Rhein Main Gebiet
Habt ihr bitte mal paar in-app Screensthots?
Mitglied
Registriert seit: Aug 2007
Beiträge: 32
Klasse Tool !!! Hab extra dafür mein iPhone gejailbreaked und es hat sich gelohnt.

Die neue Version behebt bei mir das Problem mit dem Speichern.

Teste später die Implementierung der Verbindung mittels PIN != 0000


@LinuxDoc:
Hier sind ein paar Bilder. Galerie
Mitglied
Registriert seit: May 2009
Beiträge: 129
jetzt funktioniert das Tool bei mir auch :-)

nach dem Update geht alles einfach super.
MK-Betatester
Registriert seit: Sep 2007
Beiträge: 2741
Ort: Rhein Main Gebiet
Vielen Dank für die Bilder, sieht schon mal nett aus!
Mitglied
Registriert seit: Mar 2011
Beiträge: 844
Ort: Graz
frankb meinte
Das abspeichern kann ich nachvollziehen, hat bestimmt was mit Zugriffsrechten zu tun.

Für die PIN habe ich in der neuesten Version 0.3.1 die Möglichkeit vorgesehen, dass man die manuell am Ende der Adresse angeben kann. In der Form aa:bb:cc:dd:ee:fff#0000. Ich habe es aber noch nicht richtig getestet.

Ab der Version ist jetzt auch der BTStack als Abhängigkeit definiert und wird automatisch mit installiert.


Hallo !

Verstehe das mit der Pnieingabe noch nicht ganz bei Bluetooth :

muss man nach der adresse : aa:bb:cc:dd:ee:fff dann Folgendes ohne "Space" eingeben : #0000
oder nur #0000
oder was ?
Danke für die Hilfe.

Fritz
MK-Betatester
Registriert seit: Mar 2010
Beiträge: 374
Ort: DA
@fritz: Wenn es schon mal bei dir geklappt hat, dann brauchst du nix angeben. In dem Fall wird die "0000" als Pin verwendet. Das war acuh erst mal ein Schnellschuss, das wird noch besser.
Mitglied
Registriert seit: Jul 2008
Beiträge: 591
Ort: Hanau
Habe eben die Version 0.3.1.173 installiert.
Wenn ich die App starte kommt kurz das Logo und die App beendet sich wieder.
BTstack hat er automatisch mit installiert. Daran kanns schon mal nicht liegen.
Mitglied
Registriert seit: Mar 2011
Beiträge: 844
Ort: Graz
frankb meinte
@fritz: Wenn es schon mal bei dir geklappt hat, dann brauchst du nix angeben. In dem Fall wird die "0000" als Pin verwendet. Das war acuh erst mal ein Schnellschuss, das wird noch besser.


Hallo !
Es hat bei mir nur mit WI232 funktioniert.
Mit Bluetooth noch nie !

Fritz
Mitglied
Registriert seit: May 2010
Beiträge: 108
Ort: 26759 Hinte
Hab´s auch mal getestet.

iPhone 3GS 4.2.1 mit Greenpoisen JB.
BT aus´m Shop.

Bekomme aber keine Verbindung!
Wie ist denn nun ein evtl. vorhandenes Kennwort bei der Adresse mit einzugeben?

iKopter findet zwar das Modul am Kopter, aber nachdem das "Verbinde" Quadrat für einige sekunden zu sehen ist, beendet sich die App von selbst. Nachdem es dann neu gestartet wird, ist die "Neue Verbindung" zwar noch vorhanden, aber anscheinend ist dann der Verbindungstyp "Fake Verbindung".
Auch ein evtl. vergebene Name wird IMMER ignoriert. Es erscheint in der Liste IMMER "Neue Verbindung", ein zuvor eingegebener Name ist aber in der Neuen Verbindung noch vorhanden.
MK-Betatester
Registriert seit: Mar 2010
Beiträge: 374
Ort: DA
Neuer Tag, neue Version 0.3.2.

Das ist neu:

Das abspeichern der Verbindungen klappt jetzt. Wenn man es über Cydia installiert ist der Dokumentenpfad anders :shock:

Es gibt jetzt ein extra Feld für die Pin.

Es ist jetzt ein Crash-Log-Framework eingebaut. Wenn die App abstürzt wird das beim nächsten Start bemerkt und der Crash-Log kann an meinen Server (frankblumenberg.de/crashlog) gesendet werden. Ich hoffe, dass es funktioniert und bei Fehlern weiterhilft.

Gruß
Frank
MK-Betatester
Registriert seit: Jan 2009
Beiträge: 3093
sau geil
jetzt noch die gps daten vom iphone als waypoint strunc an den kopter senden und das iFollowMe ist geboren :)

Neues Thema Antwort

Seite: 1 2 3 4 5 ... > »

MikroKopter - Forum » Subversion - Projekte » MK iPhone App - iKopter