MikroKopter - Forum » Foto & Video » FeiyuTech Brushless Gimbal

FeiyuTech Brushless Gimbal

Neues Thema Antwort

Seite: « < 1 2 3

Autor Neuer Beitrag
Mitglied
Registriert seit: Jan 2009
Beiträge: 1936
Ort: fuerstenberg
So, der Vollständigkeit halber will ich es noch erwähnen > die unkontrollierten Nick Ruckeler sind mir erhalten geblieben. Eigentlich schon von Anfang an wie mein erster Post in diesem Thread zeigt. Ich möchte gern die Nickbewegungen über meinen Sender (Poti) steuern aber das klappt nicht zufriedenstellend. Es ist mit der
Zeit (gefühlt) schlimmer geworden. Das meint > die Nick- Rucke sind recht ausgeprägt und störend. Es dabei gleichgültig in welche Position ich den Gimbalnick gesteuert habe, der Gimbal hält die Position aber er ruckt in kurzen Abständen.

Falls doch noch jemand eine Idee dazu hat, wie ich das unterbinden kann, würde ich mich darüber freuen.


Nachtrag:
habe es heute mal ohne FC-Unterstützung versucht - alles gut, keine unerwünschten Nicks.
Dazu habe ich halt das Servokabel vom FC-Port abgezogen und die Feiyu-Technik allein arbeiten lassen.

Das ist es aber nicht was ich wollte. Ich möchte schon die Nickposition mit einem Potentiometer am Sender einstellen können.
Auch wenn ich mal WP fliegen will ist ist das unverzichtbar.

Jedenfalls werden die unerwünschten Nicks von der FC ausgelöst - WARUM?
« Bearbeitet von nachtaktiv am 06.01.2018 13:50. »
Mitglied
Registriert seit: Feb 2011
Beiträge: 4815
Ort: D-15378 Hennickendorf
Hi Clemens,

könntest du das Gimbal dann nicht einfach mit Alexmos steuern? Diese Boards funzen doch eigentlich ganz vernünftig :D

Hast du evt. Ferritperlen in den Steuerleitungen drin? Die könnten ggf. was nützen...

Grüße Stephan
« Bearbeitet von Stephan Lukas am 06.01.2018 16:43. »
Mitglied
Registriert seit: Jan 2009
Beiträge: 1936
Ort: fuerstenberg
Hi Stephan, danke für die Idee. Ich denke die Gimbalsteuerung ist okay denn ohne die Verbindung zur FC arbeitet es sauber. Erst wenn ich mit einem Senderpoti die Nickfunktion über den Servoanschluß steuern möchte nickt es unkontrolliert und ungleichmäßig in Abständen von Zehntelsekunden. Zudem ist die Feiyu-Steuerelektronik nicht als separate Platine ausgeführt sondern befindet sich in den beiden Brushlessmotoren - rückseitig jeweils eine Platine.

Meinst Du Ferritperlen in der Stromzuführung oder in der Signalleitung? Einfache Ferritperlen oder kleine Ringkerne? Blöd ist auch das es ohne laufende Propeller, also am Boden nicht ungewollt nickt.

Grüße, Clemens
Mitglied
Registriert seit: Feb 2011
Beiträge: 4815
Ort: D-15378 Hennickendorf
Moin Clemens

Ich meine Ferritringe, um die dann die Signalleitungen gewickelt sind. Und hast du auch Plus noch mit dran? Den zieht man bei Alexmos ja auch raus. Also nur GND und Signal durch schleifen ;),

Grüße Stephan
Mitglied
Registriert seit: Jan 2009
Beiträge: 1936
Ort: fuerstenberg
Ja, Plus habe ich auch vom Servoport kommend mit dran. Das probiere ich mal aus - klingt vielversprechend! Plus vom Servoport lösen und einen kleinen Ringkern habe ich noch von einer Chinakameraleitung. Da fädle ich mal 2-3 Wdg der Singallleitung durch - bin gespannt! Erst mal vielen Dank für den Tip.
Mitglied
Registriert seit: Feb 2011
Beiträge: 4815
Ort: D-15378 Hennickendorf
Ich drück dir die Daumen ;)
Mitglied
Registriert seit: Dec 2010
Beiträge: 742
Ort: ZILLERTAL TIROL
nachtaktiv meinte
So, der Vollständigkeit halber will ich es noch erwähnen > die unkontrollierten Nick Ruckeler sind mir erhalten geblieben. Es dabei gleichgültig in welche Position ich den Gimbalnick gesteuert habe, der Gimbal hält die Position aber er ruckt in kurzen Abständen.

Falls doch noch jemand eine Idee dazu hat, wie ich das unterbinden kann, würde ich mich darüber freuen.
Jedenfalls werden die unerwünschten Nicks von der FC ausgelöst - WARUM?


hallo nachtaktiv !

frage: welche Version der FC hast du ?

aus eigener erfahrung kann ich dir folgendes mitteilen:
bei mir haben an einer FC 2.1 im flug immer alle 8 motore am oktokopter kurz ausgesetzt. mit "kurz" meine ich wirklich sehr sehr kurz, mann mußte schon ein gutes ohr haben um das zu hören. die aussetzer waren aber in regelmäßigen abständen zu hören - genau so, wie deine "zucker" am gimbal.

ich vermute, das die FC sich in einer programmschleife an "irgendwas" kurz aufhält und dadurch die "zucker" am servoausgang entstehen.
bei mir war es ein defekter 74HC4017 der die servos ansteuert, zuätzlich mußte noch der ATMEGA128 getauscht werden war . ich hab den defekt lange nicht bemerkt, weil ich ohne gimbal flog. H&I haben seit der FC-Version 2.5 schutzwiderstände an allen servoausgängen eingebaut.

mehrere ansätze könnten das problem lösen:
- firmware update
- FC an H&I zur überprüfung senden
- oder andere FC probieren
- 2nd empfänger mitfliegen lassen, und die nickfunktion fürs gimbal direkt anstecken

lg aus Tirol, ABH
« Bearbeitet von ABH am 09.01.2018 12:28. »
Mitglied
Registriert seit: Jan 2009
Beiträge: 1936
Ort: fuerstenberg
***** für Stephan!

Lieber Alfred, ich glaube mit Stephans Trick habe ich das Problem gelöst. Habe gerade einen kurzen Flug absolviert und KEINE UNGEWOLLTEN NICKER MEHR!
Die Drossel, bestehend aus einem Ferritring (grün, A-Durchm. 6mm, Höhe 2,5mm, 3 Wdg Signalleitung durchgefädelt) hat scheinbar geholfen. Jedenfalls ist alles gut. Hoffentlich bleibt es so.

Vielen Dank jedenfalls für Deine ausführliche Schilderung. Kannst Du mir ev. noch den Wert der Servo- Schutzwiderstände nennen sofern Du eine FC 2,5 verwendest?
Vielleicht kann es nützlich sein. Man weis ja nie . . .

Ich freue mich natürlich sehr das dieses Problem erst mal vom Tisch ist.

Grüße, Clemens
Mitglied
Registriert seit: Aug 2008
Beiträge: 56
auf der -fc_2_5 - sind es 100 ohm laut schaltplan.

und auf dem -Tiny Servo Adapter- sind es 680 ohm.

werner
Mitglied
Registriert seit: Jan 2009
Beiträge: 1936
Ort: fuerstenberg
Hallo Werner, danke für Deine Info.

- laut Schaltplan bei der FC 2,5 -

Da kann man mal sehen wie kurz mein Gehirn arbeitet :mrgreen:
Mitglied
Registriert seit: Dec 2010
Beiträge: 742
Ort: ZILLERTAL TIROL
hallo nachaktiv !

hätte nicht gedacht das sich das mit einem ferritkern beheben lässt. du fliegst ja auch 2,4ghz wie ich deinen fotos entnehmen kann.

kannst du kurz beschreiben welche anlage du fliegst und wie lange das servokabel von der FC zum gimbal ist ?
welche sendeleistung und frequenz hat dein videosender und wo ist der montiert ?
sind deine servokabel eigentlich verdrillt ?

lg alfred
Mitglied
Registriert seit: Jan 2009
Beiträge: 1936
Ort: fuerstenberg
Hallo Alfred, ich bin auch baff über diese Lösung. Hab vor dem Start noch gedacht "schön wärs" aber nicht wirklich dran geglaubt.

Das Servokabel liegt parallel, nicht verdrillt. Nur zwei Adern sind belegt, Minus und Signal. Die Ferritdrossel ist ca.
mittig in das Signalkabel eingesetzt. Von der FC bis zum Gimbal sind es 350mm Länge.

Das Video wird von der Kamera "BeastVision" auf SD Karte aufgezeichnet. Bei den geschilderten Versuchen war kein Composit- Video
in Verwendung.

Die Kamera bietet jedoch auch einen Video-OUT und wird dann über 450mm Koaxkabel an einen 25mW Sender CamOne (HIEE) angeschlossen.
Als Antenne verwende ich eine DIY CloverLeaf oder auch eine Pagoda. Videoempfänger ist dann ein 10" Monitor, auch CamOne
bzw. HIEE mit einer CL und einer Helixal. Die Kamera ist vorn und der Videosender hinten, hoch gestellt an einem Ausleger montiert.
Funktioniert soweit recht gut. Jedenfalls soweit mein Mut reicht. Ist nicht sonderlich weit ;)

Sender ist von Graupner MX-12 (uralt) umgebaut von 35MHz auf 2,4GHz Jeti Satellit und von 6 auf 9 Kanäle erweitert.

Grüße, Clemens
Mitglied
Registriert seit: Jun 2011
Beiträge: 326
Ort: zwischen Donau, Isar und Vils
nachtaktiv meinte
...
Plus vom Servoport lösen und einen kleinen Ringkern habe ich noch von einer Chinakameraleitung. Da fädle ich mal 2-3 Wdg der Singallleitung durch
...


Clemens, das interessiert mich mal genauer. War die Lösung des Problems der Ferritkern oder die Kombination Ferritkern + gelöste Plusleitung?

Armin
Mitglied
Registriert seit: Jan 2009
Beiträge: 1936
Ort: fuerstenberg
Die Plusleitung war schon abgelöst!
Ich konnte es nach dem Tip von Stephan nur nicht sehen da alles ein bisschen versteckt verbaut war. Die Plusleitung war werksseitig schon am Gimbalstecker nicht belegt. Dort wird Plus nur über den Lipoanchluß bezogen.

Um wirklich alle Änderungen zu erwähnen muss ich noch berichten das die Servo-Signalleitungsstrecke etwa 15mm kürzer wurde durch die aufgewickelten drei Windungen. Die Leitung selbst wurde nicht verkürzt denn die Windungen verbrauchen ja Kabellänge.

Schön wäre wenn ich wüsste für welche Frequenz der Ringkern ausgelegt wurde - aber das weis ich leider nicht. Kernfarbe = grün findet man bei 50 Herzdrosseln oft.

Grüße, Clemens
Mitglied
Registriert seit: Jun 2009
Beiträge: 480
Hallo Clemens,

schön dass das Problem vom Tisch ist.
Ich habe mein Gimbel mit 12V vom Flugakku versorgt und nur die Signalleitung Nick von der FC zum Gimbel geführt.
Die Servo Masse und Plus hab ich weggelassen.

Ich habe zwar eine andere FC aber warum soll man mehr Leitungen legen als nötig.

LG Michi

Nachtrag:
User image
« Bearbeitet von Opa Michi am 10.01.2018 12:09. »
Mitglied
Registriert seit: Jan 2009
Beiträge: 1936
Ort: fuerstenberg
Nachtrag - mir fällt noch ein das ich die Drähte der Signalleitung am Steckerende jetzt verlötet habe. Das war vorher nur gecrimpt. Ich musste das ja lösen um den Draht durch den Ringkern zu bekommen. Vielleicht hat auch das zur Problemlösung beigetragen.

Hallo Michael - ja bin auch froh. Das war ein eigenartiger Fehler. Und richtig - die Minusleitung vom Gimbal Signalport ist eigentlich auch überflüssig.
« Bearbeitet von nachtaktiv am 10.01.2018 12:02. »

Neues Thema Antwort

Seite: « < 1 2 3

MikroKopter - Forum » Foto & Video » FeiyuTech Brushless Gimbal