MikroKopter - Forum » Kompass » Fehler 6 Bad Compass Data und Fehler 3 No Compass Communication im Wechsel

Fehler 6 Bad Compass Data und Fehler 3 No Compass Communication im Wechsel

Neues Thema Antwort

Seite: 1

Autor Neuer Beitrag
Mitglied
Registriert seit: Aug 2008
Beiträge: 57
Moin Leute.

Ich bin dabei, eine FC1.3 mit Navi1.1 / MK3Mag und MKGPS, die ich 2008 erhalten und nie fertiggestellt hatte endlich zum Leben zu erwecken.

Firmware habe ich bei FC und Navi auf 2.00 upgedatet, Kopter Tool ist das passende, der alte 7805 wich heute einem Schaltregler aus dem Shop, und der ACT DSL4Top von damals wurde durch einen Spektrum Sat ersetzt.

Die FC macht, was sie soll, Fernsteuerung / Kanäle sind passend, alles im Kopter Tool sowohl am Akku ohne Jumper, als auch nackt USB powered. Motortest, Gyro und ACC Kalibrierung einwandfrei.

Navi / GPS sind im Tool ebenfalls sichtbar, sowohl im Turm, als auch nackt. Ohne FC meldet er auch brav "No FC communication". Eine SD Karte ist nicht in Benutzung.

Der Knopfakku dürfte leer und tiefentladen sein, schließlich lag das Ganze seit Ende 2008 nur herum. Die Meldungen bei MK3Mag hatte ich zunächst nicht beachtet, denn ich wusste ja, dass er bis Kalibrierung rot sein wird.

Also raus aus dem Haus, Funke (DX7s) an, Akku angestöpselt, eingeschaltet und versucht, den Kompass zu kalibrieren. Kein Erfolg!

Die LED am MK3Mag bleibt grün, die LED's auf der Navi 1x grün und 1x rot, die LED am GPS grün. Jeweils Dauerleuchten, kein Blinken. Knattern, Klicken oder sonstige Geräusche bleiben im Kalibriermodus aus, lediglich die Quittungstöne beim Betätigen von Nick sind da, bei Abschluss der Kalibrierung allerdings ein einfacher, kein doppelter Beep.

Also zurück in's Haus, Kopter an den PC gestöpselt und im Kopter Tool nachgeschaut. Die NaviControl gibt im Wechsel "ERR 6: Bad compass value" und "ERR 3(oder war es 4?): No compass communication" aus.

MK3Mag ausgebaut, Stiftleiste nachgelötet -kein Erfolg.
Zweite Stiftleiste vor Kopf angelötet, MK3Mag direkt über MKUSB (Jumper gesteckt, seitlicher Anschluss) an den PC und versucht, Firmware zu flashen -kein Erfolg, Timeout, Bootloader meldet sich nicht.

Habt Ihr noch Ideen?

LG
Wolfgang
Mitglied
Registriert seit: Aug 2008
Beiträge: 57
Ergänzung:

Ich habe soeben folgendes im amerikanischen Forum gefunden: http://www.mikrokopter.us/the-software/navictrl-1-1-with-2-0-firmware/
Ist es richtig, dass der MK3Mag erst auf eine neue Firmware (0.23) gebracht werden muss, ehe er mit der Navi1.1 FW2.0 zusammenarbeitet?

Welche Version vom Koptertool brauche ich dafür? Mit dem Tool der Version 2.0 geht es ja nicht.

I
Mitglied
Registriert seit: Aug 2008
Beiträge: 57
Einen Versuch habe ich vor dem Schlafengehen noch unternommen. Ich habe das Kopter Tool, das zur alten FW 0.9 passt heruntergeladen und nochmal versucht, den MK3Mag zu flashen. Zunächst Fehlanzeige, danach habe ich das Kabel von der seitlich weggehenden Stiftleiste (die für Anschluss direkt an der FC) abgezogen und an die andere (die für Anschluss an die NaviCtrl) angestöpselt und siehe da, der MK3Mag meldete sich im Kopter Tool (Terminal) und ließ sich anstandslos auf FW0.23a (war es a. ...egal) flashen.

Jetzt sitzt er wieder auf der Navi im Copter und blinkt grün vor sich hin. Kalibriert wird am Sonntag, wenn ich wieder Zeit habe.
Mitglied
Registriert seit: Aug 2008
Beiträge: 57
Aus dem Sonntag ist jetzt doch Montag geworden. Kompass ist kalibriert und alles im grünen Bereich.

Zunächst ließen sich die Motoren nicht starten, das lag aber am fehlenden GPS-Fix. Da ich überwiegend im HH Modus fliegen werde und ACC/Kompass/GPS nur als Rettungsanker und zum gelegentlichen Parken nutzen werde, habe ich die Startverhinderung bei fehlendem GPS im Tool deaktiviert.

Wäre es sinnvoll, die Kompasswirkung gleich mit auf Null zu stellen?

Neues Thema Antwort

Seite: 1

MikroKopter - Forum » Kompass » Fehler 6 Bad Compass Data und Fehler 3 No Compass Communication im Wechsel