MikroKopter - Forum » BL-Ctrl » Mysteriöse Selbstheilung von BL 3.0 Reglern

Mysteriöse Selbstheilung von BL 3.0 Reglern

Neues Thema Antwort

Seite: 1

Autor Neuer Beitrag
Mitglied
Registriert seit: Jan 2011
Beiträge: 92
Hallo zusammen,

ich habe einen Okto mit Single BL-Ctrl V3.0 2XL Reglern und Mini8 Verteiler. Nach einen Absturz habe nun zwei Abende damit rumgekämpft, weil die FC immer nur IC2 Error gemeldet hat.
So hab ich Stück für Stück alles Druchgemessen, FC getauscht, ....

Am Ende hatte ich die Regler wieder ausgebaut. Einzeln daliegen und testhalber mit einer Reserve-FC verschalten (jeweils einzeln). Immernoch IC2 Error.
Aufbau war einfach. Strom direkt an FC und BL. C/D/Masse von FC an C/D/M von BL. Status FC über MK-USB ausgelesen.

Doch nun kommts:
MK-USB direkt an Regler geklemmt, meldet dieser sich korrekt. Kann ihn auslesen. Konfigurieren alles. MK-USB wieder an FC gibts wieder den IC2 Error.
MK-USB wieder direkt Regler und nun aber mal Motortest angeworfen und Motor kurz hochdrehen lassen. Nach zurückstecken auf FC wird der Regler nun von der FC erkannt.

Das Spiel funktioniert reproduzierbar bei allen Reglern (7 Stück meldeten IC2 Error). Offensichtlich hat sich der BL verschluckt und wird softwaretechnisch wieder resetet.

Frage nun:
- was kann zu der Fehlfunktion führen, die sich durch sowas wieder korrigieren lässt?
- wie kann ich das zukünftig verhindern? Die Aktion inkl. den Ausbau macht ja echt Arbeit.
Mitglied
Registriert seit: Apr 2011
Beiträge: 3601
Ort: Münsterland
Ich hatte stets nur dann I2C-Errors, wenn die ESCs2.0 auf dem Träger nicht sauber verlötet waren. Bei den BL3.0 hatte ich das noch nie.
Schau dir die Lötstellen an, reinige vor allem die C+D-Anschlüsse mit Spiritus, dann sollte es gut sein!
Mitglied
Registriert seit: Jan 2011
Beiträge: 92
Ich gehe davon aus, das die IC2 Fehler beim BL3 seltener/weg sind, weil es entweder vollintegrierte Platinen sind oder die Verbinder gesteckt werden.
So auch in meinen Fall. Die Regler sind mit dem Mini8 Verteiler über Molex Verbinder zustammengesteckt gewesen. Da bleiben als schwache Lötstellen nur noch
der Stromanschluss.
Mitglied
Registriert seit: Dec 2010
Beiträge: 2430
Ort: Bei mir zu Hause.
Wenn du den unter der Grasnarbe geparkt hast, kann bei der aktuellen Wetterlage und hoher
Luftfeuchtigkeit immer noch ein bischen restfeuchtigkeit zwischen den SMD's gewesen sein,
die sich dann bei der Erwärmung durch den Motortest verflüchtigt hat.

Neues Thema Antwort

Seite: 1

MikroKopter - Forum » BL-Ctrl » Mysteriöse Selbstheilung von BL 3.0 Reglern