MikroKopter - Forum » Newbie - Bereich » Missing BL und I2C error

Missing BL und I2C error

Neues Thema Antwort

Seite: 1

Autor Neuer Beitrag
Mitglied
Registriert seit: Jan 2011
Beiträge: 18
hallo,
hat vielleicht jemand einen Tip für mich bitte?

Okto xl gibt seit längerem die Fehlermeldungen "missing BL" und "I2c error".
Er fliegt aber mit diesen Meldungen im Jeti unter gepiepse fast tadellos. Nur gelegentliche Rüttler allerdings.
Passiert eher beim Gas geben. Im Stand seltener.
Was auch manchmal passiert und seltsam ist, während die Motoren nicht laufen meldet sich gelegentlich eines und
dreht plötzlich den Propeller um halbe Drehung.
Ich habe schon mehrfach die gesamte Verteilerplatte/Regler nachgelötet, weil es nach Masse-fehler aussah.
Ich kann mir vorstellen, dass die erfahrenen unter Euch so etwas bestimmt kennen.
Danke im Voraus.
Bora
Mitglied
Registriert seit: Jun 2013
Beiträge: 1261
Ort: Luxembourg
bora66 meinte
Okto xl gibt seit längerem die Fehlermeldungen "missing BL" und "I2c error".
Er fliegt aber mit diesen Meldungen im Jeti unter gepiepse fast tadellos. Nur gelegentliche Rüttler allerdings.
Passiert eher beim Gas geben. Im Stand seltener.
Was auch manchmal passiert und seltsam ist, während die Motoren nicht laufen meldet sich gelegentlich eines und
dreht plötzlich den Propeller um halbe Drehung.
Ich habe schon mehrfach die gesamte Verteilerplatte/Regler nachgelötet, weil es nach Masse-fehler aussah.
Ich kann mir vorstellen, dass die erfahrenen unter Euch so etwas bestimmt kennen.

I presume you have BL-Motor-Ctrl V2, correct?

It can be that one of the electrolytic capacitors (DE: Elko) are broken or the leg into the capacitor is broken from vibrations. Read the thread: Weird error18

I2C problems during flight should NOT be ignored. They are indication of a problem on the micro-copter. Until resolved, only fly for test purpose and far away from any persons.

Feel free to answer auf Deutsch.
Mitglied
Registriert seit: Jan 2011
Beiträge: 18
Hallo Foersom,
Danke für Deine Tips.
Äußerlich sehen die Elkos ok aus. Keine Wölbungen.
In dem Thread was Du verlinkt hast ist die Rede vom Kleben der Elkos... was klebt Ihr da wohin bitte?
Mitglied
Registriert seit: Jun 2013
Beiträge: 1261
Ort: Luxembourg
bora66 meinte
In dem Thread was Du verlinkt hast ist die Rede vom Kleben der Elkos... was klebt Ihr da wohin bitte?

I am not sure about your last sentence. Each of the 8 BL-Motor-Ctrl has 2 electrolytic capacitors on the under side. They are unfortunately difficult to access, you have to take main board (power board) out. The capacitors are bended and glued to the edges of the FETs. I used simple general strong glue Henkel DuroBond.

Edit: Found an old wiki page that shows glueing the capacitors.
« Bearbeitet von Foersom am 30.08.2016 09:40. »
Mitglied
Registriert seit: Jan 2011
Beiträge: 18
I was wondering about glueing the capacitors... I was soldering hundert times capacitors in and out in the past. never heard about glueing anything.
Mitglied
Registriert seit: Jun 2013
Beiträge: 1261
Ort: Luxembourg
bora66 meinte
I was wondering about glueing the capacitors... I was soldering hundert times capacitors in and out in the past. never heard about glueing anything.

The big problem on the micro-copters are millions of tiny vibrations. Large components, like the elkos and DC-DC (Recom or Traco) can break over a matter of weeks or month if not glued in place. See thread: Ich habe da mal was verloren...

I broke a handful of DC-DC converters before I figured out to fix them in place using adhesive tape. However for the capacitors glue is better.
« Bearbeitet von Foersom am 30.08.2016 09:20. »
Mitglied
Registriert seit: Jan 2011
Beiträge: 18
I see. I can't bend the elkos anymore coz was keeping the legs very short. maybe that's why they never broke.
The elkos seem ok so far. I can Imagine its about my bad soldering what causing the problems. I did a lot soldering but never in a good way. Thinking of sending both kopters in for repairing. the second kopter is a trash after crashing 3 years ago.

Neues Thema Antwort

Seite: 1

MikroKopter - Forum » Newbie - Bereich » Missing BL und I2C error