MikroKopter - Forum » Newbie » No GPS communication error

No GPS communication error

Neues Thema Antwort

Seite: 1

Autor Neuer Beitrag
Mitglied
Registriert seit: Oct 2015
Beiträge: 2
Hello everyone,

I've purchased a used octocopter with Mikrokopter components. The kopter has v2.0 FC, v1.1 NC and v.1.0 GPS. Everything works fine except GPS. I've upgraded FC and Navi fw to v2.10c and MK tool says no GPS communication. When I click on MKGPS in Mktool it's searching for satelites but gives no time and fix. I've tried to transfer gps config file from here http://files.mikrokopter.de/MKGPS_01_2008a.txt via U-center and after that Mktool shows no error. The problem is that it lasts only until I cut off power from my copter. After cutting of power Mktool shows again "no GPS communication" error. I've replaced GPS battery with new one but it didn't help. I've also set gpsautoconfig to 0 on my SD card. Do you have any ideas how to solve this problem ?

Thank in advance,
Gregor
Mitglied
Registriert seit: Apr 2011
Beiträge: 3556
Ort: Münsterland
GPSautoconfig has to set on 1!
Maybe there is a problem with that cable
https://www.mikrocontroller.com/index.php?main_page=product_info&cPath=111&products_id=318&zenid=g1701dkoqes6e5je632shiqr94

The Batterie has nothing to do with your problem!
The Problem is, that the Navi can't config the GPS
Mitglied
Registriert seit: Oct 2015
Beiträge: 2
I did change gpsautoconfig to 1 and it didn't help. After that I downgraded FC to v2.0e and NC to v2.0f and it's autoconfiguring gps only after I click on SD card in MKtool and shows no error but after I cut off batterry I get "no gps connection error" again.

edit.
I did reinit EEPROM and it's now finding my GPS and calibrating it. Seems like it was compatibility issue.

edit2.

It's now working with v2.08 (had to reinit EEPROM few times).

v2.10
Changed: GPS version detection

Guess that's my problem
« Bearbeitet von Inen am 06.10.2015 16:13. »

Neues Thema Antwort

Seite: 1

MikroKopter - Forum » Newbie » No GPS communication error