MikroKopter - Forum » BL-Ctrl » Kälteproblem?

Kälteproblem?

Neues Thema Antwort

Seite: 1

Autor Neuer Beitrag
Mitglied
Registriert seit: Sep 2010
Beiträge: 3083
Ort: Emmental
Derzeit ist es ja saukalt, aber manschmal muss oder will man trotzdem Fliegen.
Nun habe ich gestern festgestellt das bei einem Kopter wenn dieser unter Null Grad hat beim Einschalten
error18 ("ERR: Bl Missing") kommt. Sobals der Kopter wieder warm ist ist der Fehler auch weg.
Ich habe das mehrmals wiederholt.
Bei einem anderen Kopter konnte ich das nicht feststellen.
Hat jemand eine Ahnung was das sein könnte?
Mitglied
Registriert seit: Mar 2009
Beiträge: 2765
Hatte ich auch mal. Ist ein Hardware Fehler einer Charge der FC. Ebenso ein Fehler bei einer NC.Ich glaub, damals funktionierte der Compass in der Kälte nicht. Ist schon eine Weile aus, und ein bekanntes Hardware Problem. Nur Fehler bei MK werden halt nicht publitiert,man kommt ja eh ohnehin selbst drauf, wenn es nicht geht oder es einen runter haut. Ich glaub, ich hab meine Hardware damals an H+I geschickt, die haben das dann repariert. Deren Support ist ja legendär schnell und unkompliziert.
Mitglied
Registriert seit: Jun 2013
Beiträge: 1261
Ort: Luxembourg
Karakara meinte
Derzeit ist es ja saukalt, aber manschmal muss oder will man trotzdem Fliegen.
Nun habe ich gestern festgestellt das bei einem Kopter wenn dieser unter Null Grad hat beim Einschalten
error18 ("ERR: Bl Missing") kommt. Sobals der Kopter wieder warm ist ist der Fehler auch weg.
Ich habe das mehrmals wiederholt.
Bei einem anderen Kopter konnte ich das nicht feststellen.
Hat jemand eine Ahnung was das sein könnte?

When you get error 18 it is usually because of broken electrolytic capacitor (DE: Elko) on the BL-Motor-Ctrl power board.

As you mention it is related to temperature it could be that one leg of a capacitor is broken and because of metal expanding (warm) and retracting (cold) it sometimes have connection, sometimes no connection. It could also be a soldering / solder pad of a capacitor that is broken.

Read thread: Wierd error 18

Feel free to answer auf Deutsch.
Mitglied
Registriert seit: Sep 2010
Beiträge: 3083
Ort: Emmental
Danke für die Antwort, ich werde mir das mal ansehen.
Aber ich kann mir das nicht so recht vorstellen wieso dann der Fehler auftritt wenn der Regler nach seiner eigenen Messung unter Null Grad hat.
Mitglied
Registriert seit: Mar 2011
Beiträge: 171
Ort: Münsterland
Das gleiche konnte ich auch schon beobachten, über 2 Winter hinweg. Wenn es zu kalt (ab knapp über 0 Grad) wurde, BC Error... Allerdings auch nicht immer.
An wärmeren Tagen konnte ich diesen Effekt noch nicht beobachten.

(Redundanter Okto-Verteiler, FC 2.5 (Master + Slave)
Mitglied
Registriert seit: Apr 2010
Beiträge: 6710
Ort: München
Fehlermeldung durch Kondensbildung?
Mitglied
Registriert seit: Sep 2010
Beiträge: 3083
Ort: Emmental
Das halte ich für unwahrscheinlich. Kondensation (Feuchtigkeit) gibts ja normal von kalt nach warm. Aber sobald ich den Kopter drinnen etwas aufwärmen lasse ist der Fehler weg. Und wenn der Kopter wieder draussen unter Null Grad hat ist der Fehler wieder da.
Mitglied
Registriert seit: Apr 2010
Beiträge: 6710
Ort: München
Nun,ich dachte an ein BL Ctrl. der durch Betrieb erwärmt wird,und dann im Flugbetrieb durch anströmende Kaltluft
und Kondensbildung eben diese Fehlermeldung produzieren könnte...aber gut.
« Bearbeitet von blosmi am 27.01.2017 10:54. »
Mitglied
Registriert seit: Dec 2011
Beiträge: 48
Ort: Magdeburg
Karakara meinte
Das halte ich für unwahrscheinlich. Kondensation (Feuchtigkeit) gibts ja normal von kalt nach warm. Aber sobald ich den Kopter drinnen etwas aufwärmen lasse ist der Fehler weg. Und wenn der Kopter wieder draussen unter Null Grad hat ist der Fehler wieder da.


Hallo Karakara,

ich kann mich da so nicht Deiner Meinung anschließen, setzt Dich mal bei den Temperaturen ins Auto und schau mal von welcher Seite die Scheiben beschlagen.


Gruß Martin
Mitglied
Registriert seit: Sep 2010
Beiträge: 3083
Ort: Emmental
Der Fehler tritt nicht im Flug auf sondern direkt beim Einschalten.
Mitglied
Registriert seit: Sep 2010
Beiträge: 3083
Ort: Emmental
Yak54 meinte
Karakara meinte
Das halte ich für unwahrscheinlich. Kondensation (Feuchtigkeit) gibts ja normal von kalt nach warm. Aber sobald ich den Kopter drinnen etwas aufwärmen lasse ist der Fehler weg. Und wenn der Kopter wieder draussen unter Null Grad hat ist der Fehler wieder da.


Hallo Karakara,

ich kann mich da so nicht Deiner Meinung anschließen, setzt Dich mal bei den Temperaturen ins Auto und schau mal von welcher Seite die Scheiben beschlagen.


Gruß Martin


Da ist aber eine Wärmequelle (Mensch) vorhanden, beim Kopter ist alles kalt.
Mitglied
Registriert seit: Apr 2010
Beiträge: 6710
Ort: München
Tritt der Fehler auf,wenn Du den Kopter nicht unter Strom setzt?NEIN...klar
Setzt Du ihn unter Strom,fließt Strom und der Bl.Ctrl. erwärmt sich!
Und der Kopter stand davor nicht schon eine Stunde im Freien,sondern wurde aus einem wärmeren
Raum dorthin gestellt.
Da hast Du beim heraus heben aus dem Kofferaum schon Kondensfilm.
Aber wenn Du das nicht als mögliche Fehlerquelle sehen magst,wünsche ich trotzdem gutes Gelingen bei der Fehlerfindung.
Mitglied
Registriert seit: Sep 2010
Beiträge: 3083
Ort: Emmental
Gut, kurzfassung:
- Kopter ist im warmen vor dem Einsatz, wir nach drausen gebracht (Kopter ist noch warm), einschalten, kein Problem, keine Fehlermeldung.
- Kopter steht seit einer halben Stunde oder so stromlos bei minus 5...10 Grad Celsius drausen, Kopter wird eingeschaltet: Error 18.
Mitglied
Registriert seit: Feb 2011
Beiträge: 4714
Ort: D-15378 Hennickendorf
Hallo,

ist das bei dir vllt. das selbe Problem wie hier?

http://forum.mikrokopter.de/topic-52206.html

Grüße Stephan
Mitglied
Registriert seit: Sep 2010
Beiträge: 3083
Ort: Emmental
Danke, ich hab's mal mit google übersetzt um was zu verstehen.
So wie ich das sehe sind das zwei verschiedene Probleme. Ich habe kein Problem mit der Kalibrierung.
Mitglied
Registriert seit: Feb 2011
Beiträge: 4714
Ort: D-15378 Hennickendorf
Mein iPhone übersetzt mir die fremdsprachigen Artikel automatisch :-)
Entwickler, Admin
Registriert seit: Feb 2006
Beiträge: 5789
Ort: Ostfriesland
Das muss ein BL-Regler sein, der da nicht läuft.
Ist eine LED auf den BL-Reglern dann rot, oder alle?
Ich habe es schon gesehen, dass ein BL-Regler nicht anläuft, wenn er feucht ist. Aber bei Kälte ist mir das neu.
Mitglied
Registriert seit: Sep 2010
Beiträge: 3083
Ort: Emmental
Danke für die Rückmeldung.
Was die LED angezeigt haben kann ich wegen der Haube nicht sagen, werde das aber nachhohlen sobald es wieder entsprechend kalt ist. Die letzte Nacht war die erste seit langem ohne Frost.
Entwickler, Admin
Registriert seit: Feb 2006
Beiträge: 5789
Ort: Ostfriesland
Ansonsten kannst Du im Virtuellen Display die Versionsnummern sehen. Da fehlt dann ggf. eine
Mitglied
Registriert seit: Mar 2011
Beiträge: 171
Ort: Münsterland
Wenn es so ist wie bei mir, dann ist von den LED alles in Ordnung. Zumindest am Boden.
Es ist auch so, dass man erst 10 Minuten fliegen kann... dann kommt kurz der Fehler... und dann ist er 2 Minuten weg... dann kommt er wieder. Man landet, schaut nach... alles (optisch) in Ordnung, auch auf der Platine.... dann nochmal starten... wieder ein paar Minuten später dann nochmal der Fehler. Teilweise vereinzelt. -> Flugabbruch
am nächsten Tag das gleiche... ähnliche Wetterbedingungen... und dann bei etwas wärmeren Temperaturen funktioniert wieder alles.

LOG-File zeigt dann auch "alles OK" an. Nur halt nicht bei der Fehlerdurchsage.
Feuchtigkeit war mit bloßem Auge nicht erkennbar, vom Wetter (Kondensierung) her könnte es aber passen.
Der Fehler tauchte bei mir bei 2 Einsätzen auf und bei einem Testflug an einem Folgetag.
Mitglied
Registriert seit: Sep 2010
Beiträge: 3083
Ort: Emmental
Bei mir ist der Fehler nur beim Initialisieren da. Wenn ich den Kopter ohne Fehlermeldung einschalten kann, also einschalten bei Reglertemperatur über Null Grad, dann kann ich auch normal fliegen und es gibt auch im Flug keine Probleme.

Das mit dem Virtuellen Display ist an sich eine gute Idee, nur bin ich meist ohne PC am Fliegen. Wenn überhaupt ich ich ein Tablet dabei.

Neues Thema Antwort

Seite: 1

MikroKopter - Forum » BL-Ctrl » Kälteproblem?